Home Forums Xblog Pro HOW to show that there is a link

Tagged: 

Viewing 10 posts - 1 through 10 (of 10 total)
  • Author
    Posts
  • #2238
    Kent Busse
    Participant

    When I link text to a URL the process works. However, the reader does not SEE that there is a link. Web pages show linked text in a different color (or underscored) show yet another color after the link has been clicked. This makes an article much easier to use.

    #2245
    Theme space
    Keymaster

    Hi,
    Thank you for your question.
    You want to change the link text color.
    You can easily change the link text color by the customize setting go customize -> color setting -> link color and change your own color for link.
    I hope now you can change the color.
    Thanks again

    #2262
    Kent Busse
    Participant

    It is great that you thought of this already. However, I CAN’T FIND IT. I have customize -> Colors -> [list]
    The [list] is Classic header background color | Header Text Color | Background Color | Theme color | Use container background color | Choose container background color | Use custom content color.

    I am in xblog pro child theme. Is that right?

    #2264
    Kent Busse
    Participant

    I looked for this setting again and still cannot find it. I need it quite urgently!

    #2266
    Theme space
    Keymaster

    Hi,
    I’ve updated XBLOG PRO theme and added options for custom link color.
    So please update the theme and use your won color for link.
    Thanks

    #2269
    Kent Busse
    Participant

    Thank you! I needed that help. It works now.

    NOTE: I did not know how to do this. I just clicked on “update theme” in WordPress, and my CHILD theme disappeared. I could not customize because WP told me the directory no longer exists. I reinstalled the CHILD theme from my previous download. [I RESTORED my backup WP files.] Now Chrome browser shows the header text color the same as the custom link color. I chose BLACK header text color again, and now Edge and Chrome (incognito) do show me the black header text, but regular Chrome browser remembers who I am and shows me the BLUE (link color) header text. Of course I will live with this, so long as my customers see the black text.

    Maybe there is a better way that I should have updated the theme.

    #2279
    Kent Busse
    Participant

    UPDATED REPLY — after hours of testing
    To make this easier I use these conventions: normal text is BLACK. link text is BLUE. hover (highlight) is RED.
    Note: items marked “red” below turn DIM RED on hover. Right effect, wrong link color before hover.

    Within an individual post, you gave me just what I want: black text, blue link, red hover. Now it is time to debug a LOT of other places.

    1. The SITE TITLE has its own color black. In WordPress PREVIEW MODE that turns to red on hover, back to black when the mouse leaves.
    In a normal browser (Chrome, Edge), the SITE TITLE is red all the time everywhere.
    Regular browsing on somebody else’s computer (not using my user ID) the SITE TITLE is also red.
    In incognito browsing, the SITE TITLE is black (the color I chose for it) and it turns red on hover and black when the mouse moves away. That is all right. But in regular viewing, it is always red after that.

    2. Site BLOG settings
    individual post headings and “Read more” are red if I have EVER clicked on them. Incognito, they are black and “Read more” is blue.
    All sidebar links I have ever clicked are red. Before I click them they are blue.

    3. Single blog settings (reading ONE POST)
    “Looged in as …” is red.
    dates & categories under images are red if I have ever clicked on them.
    “You may also like” band: post titles are black (dim on hover) and dates are blue (dim red on hover) until I have clicked on them. After that they stay red.
    in incognito browsing, these items work as they should.

    4. The FLOATING MENU seems to be correct in all situations: black lettering with dim (gray) on hover, back to black.

    I am satisfied with the behavior in an incognito browser, but for normal browsing the color scheme is truly erratic. I look forward to some improvements.

    The improvement I wanted was that INSIDE A BLOCK (paragraph) INSIDE ONE SINGLE POST the link should be blue with a red hover cover that goes back to blue when the mouse is not on the link. EVERYWHERE else, I really want to go back to the DEFAULT WP BEHAVIOR (black that turns grey on hover, back to black when the mouse moves away). Blue and red do NOT help in the footers and sidebars because readers already know that the respective items are links.

    #2281
    Kent Busse
    Participant

    I am trying to delete my earlier reply and do not know how to do that. It looks as if I should reinstall your previous Pro theme and again reinstall your child theme to get back to where things were. Maybe I can hand code links inside paragraphs (Gutenberg).

    #2282
    Kent Busse
    Participant

    I just realized that I can turn the custom link color switch OFF by unchecking the box. Now I will relax. I hope you can delete my long debugging report message.

    #2288
    Kent Busse
    Participant

    SUMMARY: After several days, I am satisfied to use the latest X Blog update and set the custom link colors to [link] = light blue; [hover] = BLACK.
    All I wanted was blog posts where has the HTML DEFAULT behavior. Now we are getting closer to that goal, although I don’t know why we had to work so hard to produce default behavior.

    When WP recognizes me in the browser (Chrome), the link color is standard text color which dims on hover. In an incognito window, the links are light blue and they turn to black on hover. Outside the paragraphs in a post, the headers now stay black and the SIDEBAR links are all blue. I can live with that.

Viewing 10 posts - 1 through 10 (of 10 total)
  • You must be logged in to reply to this topic.